hostname R1

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

no ip icmp rate-limit unreachable

ip cef

!

ip vrf RAKNET

 description RAKNET

 rd 510:100

 route-target export 510:100

 route-target import 510:100

!

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

mpls label protocol ldp

!

interface Loopback1

 description GLOBAL-RT-LOOPBACK

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback100

 description RAKNET-100

 ip vrf forwarding RAKNET

 ip address 192.168.100.1 255.255.255.255

!

interface Ethernet0/0

 no ip address

 shutdown

 duplex auto

!

interface GigabitEthernet0/0

 description LINK-R2

 ip address 100.64.0.1 255.255.255.252

 duplex auto

 speed auto

 media-type gbic

 negotiation auto

!

interface GigabitEthernet1/0

 description LINK-R3

 ip address 100.64.0.5 255.255.255.252

 negotiation auto

!

interface GigabitEthernet2/0

 no ip address

 negotiation auto

 xconnect 2.2.2.2 510001 encapsulation mpls

!

router ospf 100

 mpls ldp autoconfig

 router-id 1.1.1.1

 log-adjacency-changes

 network 1.1.1.1 0.0.0.0 area 0

 network 100.64.0.0 0.0.0.3 area 0

 network 100.64.0.4 0.0.0.3 area 0

!

router bgp 510

 no synchronization

 bgp log-neighbor-changes

 network 0.0.0.0

 network 8.8.8.8 mask 255.255.255.255

 redistribute connected

 neighbor 2.2.2.2 remote-as 510

 neighbor 2.2.2.2 update-source Loopback1

 neighbor 2.2.2.2 next-hop-self

 neighbor 3.3.3.3 remote-as 510

 neighbor 3.3.3.3 update-source Loopback1

 neighbor 3.3.3.3 next-hop-self

 neighbor 100.10.10.2 remote-as 510

 no auto-summary

 !

 address-family vpnv4

  neighbor 2.2.2.2 activate

  neighbor 2.2.2.2 send-community extended

  neighbor 3.3.3.3 activate

  neighbor 3.3.3.3 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf RAKNET

  redistribute connected

  no synchronization

 exit-address-family

By matthew

Leave a Reply